Security Risk Disclosed in Internet Explorer

A security research firm is warning that all versions of Microsoft's Internet Explorer are at risk from a vulnerability that could trigger a denial of service attack on end-users. According to Determina, the vulnerabilities in Internet Explorer alleged by Determina could potentially have a wide spread impact since they affect all versions of IE on Windows 2000, XP, 2003 and Vista including the latest IE 7.

  • Read the article: